Help Centre / Canolfan Gymorth
Search / Chwilio:     Advanced search / Chwilio uwch
Browse by category / Pori yn ol y categori:
Downloads / Llwytho i lawr | Glossary / Geirfa |

Browser Requirements

Article ID / Rhif erthygl: 25
Last updated / Diweddarwyd: 02 Mar, 2015
Views / Ymweliadau: 64

Blackboard officially requires Microsoft Internet Explorer (5.2 on Mac, 5.5 or later on PC), Netscape (7.1 or later), or Apple Safari (1.1 or later, Mac only). Recent versions of Firefox and Mozilla will also work.

See the Blackboard End User Configuration Guide.

Additionally, you must have JavaScript, ActiveX and Cookies enabled within your browser. To use the Blackboard Collaboration Tool the Java Plug-In is required, Please note that the Java Plug-In is NOT the same as Javascript, and can be downloaded freely from Sun.

Anyone can test their browser settings by using this interactive browser checker

Please rate the article and leave a comment.  Thank you!


To check if your browser settings are up to scratch, please use our Blackboard Browser Check Site.

View this article in Welsh

This article was / Roedd yr erthygl hon yn:   Helpful | Not Helpful
Prev / Blaenorol   Next / Nesaf
Getting Started     How can I use Blackboard in Welsh or another Language?

Others in this Category / Eraill yn y Categori hwn
document Can I set a specific language for a particular module? (STAFF)
document Can I use a different language?
document I want to set up a new course shell. How do I go about this?
document My students can't see my modules / I see unavailable alongside my modules/ How do I make my course available (STAFF)
document How can I allow "outsiders" to have a look at my course module? STAFF
» More articles / Mwy o erthyglau